CVE-2018-10888

MEDIUM

Description

A flaw was found in libgit2 before version 0.27.3. A missing check in git_delta_apply function in delta.c file, may lead to an out-of-bound read while reading a binary delta file. An attacker may use this flaw to cause a Denial of Service.

References

https://bugzilla.redhat.com/show_bug.cgi?id=1598024

https://github.com/libgit2/libgit2/commit/9844d38bed10e9ff17174434b3421b227ae710f3

https://github.com/libgit2/libgit2/releases/tag/v0.27.3

https://lists.debian.org/debian-lts-announce/2018/08/msg00024.html

Details

Source: MITRE

Published: 2018-07-10

Updated: 2019-10-09

Type: CWE-125

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.8

Severity: MEDIUM