MySQL 8.0.x < 8.0.13 Multiple Vulnerabilities (Oct 2018 CPU) (Jul 2019 CPU)

High Nessus Plugin ID 118236

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL running on the remote host is 8.0.x prior to 8.0.13. It is, therefore, affected by multiple vulnerabilities as noted in the October 2018 Critical Patch Update advisory. Please consult the CVRF details for the applicable CVEs for additional information.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MySQL version 8.0.13 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/8.0/en/news-8-0-13.html

http://www.nessus.org/u?705136d8

Plugin Details

Severity: High

ID: 118236

File Name: mysql_8_0_13.nasl

Version: 1.3

Type: remote

Family: Databases

Published: 2018/10/19

Updated: 2019/07/18

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2016-9843

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Patch Publication Date: 2018/10/16

Vulnerability Publication Date: 2017/05/23

Reference Information

CVE: CVE-2016-9843, CVE-2018-3133, CVE-2018-3137, CVE-2018-3143, CVE-2018-3144, CVE-2018-3145, CVE-2018-3155, CVE-2018-3156, CVE-2018-3161, CVE-2018-3162, CVE-2018-3170, CVE-2018-3171, CVE-2018-3173, CVE-2018-3174, CVE-2018-3182, CVE-2018-3185, CVE-2018-3186, CVE-2018-3187, CVE-2018-3195, CVE-2018-3200, CVE-2018-3203, CVE-2018-3212, CVE-2018-3247, CVE-2018-3251, CVE-2018-3276, CVE-2018-3277, CVE-2018-3278, CVE-2018-3279, CVE-2018-3280, CVE-2018-3282, CVE-2018-3283, CVE-2018-3284, CVE-2018-3285, CVE-2018-3286, CVE-2019-2743, CVE-2019-2746, CVE-2019-2747

BID: 105594, 105600, 105607, 105610, 105612, 109239, 95131