PostgreSQL 9.3.x < 9.3.24 / 9.4.x < 9.4.19 / 9.5.x < 9.5.14 / 9.6.x < 9.6.10 / 10.x < 10.5 Multiple Vulnerabilities

High Nessus Plugin ID 111966

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of PostgreSQL installed on the remote host is 9.3.x prior to 9.3.24, 9.4.x prior to 9.4.19, 9.5.x prior to 9.5.14, 9.6.x prior to 9.6.10, or 10.x prior to 10.5. It is, therefore, affected by multiple vulnerabilities.

Solution

Upgrade to PostgreSQL version 9.3.24 / 9.4.19 / 9.5.14 / 9.6.10 / 10.5 or later.

See Also

https://www.postgresql.org/about/news/1878/

https://www.postgresql.org/docs/current/release-9-3-24.html

https://www.postgresql.org/docs/current/static/release-9-4-19.html

https://www.postgresql.org/docs/current/release-9-5-14.html

https://www.postgresql.org/docs/current/static/release-9-6-10.html

https://www.postgresql.org/docs/current/static/release-10-5.html

Plugin Details

Severity: High

ID: 111966

File Name: postgresql_20180809.nasl

Version: 1.6

Type: local

Family: Databases

Published: 2018/08/17

Updated: 2019/02/26

Dependencies: 63346

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-10915

CVSS v2.0

Base Score: 7.1

Vector: CVSS2#AV:N/AC:H/Au:S/C:C/I:C/A:C

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2018/08/09

Vulnerability Publication Date: 2018/08/09

Reference Information

CVE: CVE-2018-10925, CVE-2018-10915

BID: 105052, 105054