PostgreSQL 9.3.x < 9.3.24 / 9.4.x < 9.4.19 / 9.5.x < 9.5.14 / 9.6.x < 9.6.10 / 10.x < 10.5 Multiple Vulnerabilities

Medium Nessus Plugin ID 111966

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.7


The remote database server is affected by multiple vulnerabilities.


The version of PostgreSQL installed on the remote host is 9.3.x prior to 9.3.24, 9.4.x prior to 9.4.19, 9.5.x prior to 9.5.14, 9.6.x prior to 9.6.10, or 10.x prior to 10.5. It is, therefore, affected by multiple vulnerabilities.


Upgrade to PostgreSQL version 9.3.24 / 9.4.19 / 9.5.14 / 9.6.10 / 10.5 or later.

See Also

Plugin Details

Severity: Medium

ID: 111966

File Name: postgresql_20180809.nasl

Version: 1.7

Type: local

Family: Databases

Published: 2018/08/17

Updated: 2019/11/04

Dependencies: 63346

Risk Information

Risk Factor: Medium

VPR Score: 6.7

CVSS Score Source: CVE-2018-10915

CVSS v2.0

Base Score: 6

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/08/09

Vulnerability Publication Date: 2018/08/09

Reference Information

CVE: CVE-2018-10915, CVE-2018-10925

BID: 105052, 105054