CVE-2018-10915

MEDIUM

Description

A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections. If an affected version of libpq was used with "host" or "hostaddr" connection parameters from untrusted input, attackers could bypass client-side connection security features, obtain access to higher privileged connections or potentially cause other impact through SQL injection, by causing the PQescape() functions to malfunction. Postgresql versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 are affected.

References

http://www.securityfocus.com/bid/105054

http://www.securitytracker.com/id/1041446

https://access.redhat.com/errata/RHSA-2018:2511

https://access.redhat.com/errata/RHSA-2018:2557

https://access.redhat.com/errata/RHSA-2018:2565

https://access.redhat.com/errata/RHSA-2018:2566

https://access.redhat.com/errata/RHSA-2018:2643

https://access.redhat.com/errata/RHSA-2018:2721

https://access.redhat.com/errata/RHSA-2018:2729

https://access.redhat.com/errata/RHSA-2018:3816

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10915

https://lists.debian.org/debian-lts-announce/2018/08/msg00012.html

https://security.gentoo.org/glsa/201810-08

https://usn.ubuntu.com/3744-1/

https://www.debian.org/security/2018/dsa-4269

https://www.postgresql.org/about/news/1878/

Details

Source: MITRE

Published: 2018-08-09

Updated: 2019-10-03

Type: CWE-89

Risk Information

CVSS v2.0

Base Score: 6

Vector: AV:N/AC:M/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 6.8

Severity: MEDIUM

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.6

Severity: HIGH