PHP 7.3.0 [alpha|beta] < 7.3.0 Multiple vulnerabilities

High Nessus Plugin ID 111217


An application installed on the remote host is affected by multiple vulnerabilities.


According to its banner, the version of PHP running on the remote web server is 7.3.0 [alpha|beta] prior to 7.3.0. It is, therefore, affected by multiple vulnerabilities:

- An arbitrary command injection vulnerability exists in the imap_open function due to improper filters for mailbox names prior to passing them to rsh or ssh commands. An authenticated, remote attacker can exploit this by sending a specially crafted IMAP server name to cause the execution of arbitrary commands on the target system. (CVE-2018-19518)

- A denial of service vulnerability exists in the imap_mail function due to improper data validation. An unauthenticated, remote attacker can exploit this via an empty string in the message argument to the imap_mail function to cause the application to stop responding.

- A heap buffer over-read exists in the phar_parse_pharfile function.
An unauthenticated, remote attacker can exploit this to read allocated or unallocated memory past the actual data when trying to parse a .phar file. (CVE-2018-20783)


Upgrade to PHP version 7.3.0 or later.

See Also

Plugin Details

Severity: High

ID: 111217

File Name: php_7_3_0.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 2018/07/20

Updated: 2019/03/04

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-19518

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2018/07/19

Vulnerability Publication Date: 2018/06/03

Reference Information

CVE: CVE-2018-19518, CVE-2018-19935, CVE-2018-20783

BID: 106018, 106143, 107121