FreeBSD : Flash Player -- multiple vulnerabilities (e78732b2-8528-11e8-9c42-6451062f0f7a)

High Nessus Plugin ID 111020

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

Adobe reports :

- This update resolves an out-of-bounds read vulnerability that could lead to information disclosure (CVE-2018-5008).

- This update resolves a type confusion vulnerability that could lead to arbitrary code execution (CVE-2018-5007).

Solution

Update the affected package.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb18-24.html

http://www.nessus.org/u?7cf5acbd

Plugin Details

Severity: High

ID: 111020

File Name: freebsd_pkg_e78732b2852811e89c426451062f0f7a.nasl

Version: 1.1

Type: local

Published: 2018/07/12

Modified: 2018/07/12

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:linux-flashplayer, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/07/11

Vulnerability Publication Date: 2018/07/10

Reference Information

CVE: CVE-2018-5007, CVE-2018-5008