openSUSE Security Update : MozillaFirefox (openSUSE-2018-676)

high Nessus Plugin ID 110801
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 6.7

Synopsis

The remote openSUSE host is missing a security update.

Description

This security update for MozillaFirefox to version 60.1.0esr fixes multiple issues.

Security issues fixed (MFSA 2018-16, boo#1098998) :

- CVE-2018-12359: Buffer overflow using computed size of canvas element

- CVE-2018-12360: Use-after-free when using focus()

- CVE-2018-12361: Integer overflow in SwizzleData

- CVE-2018-12362: Integer overflow in SSSE3 scaler

- CVE-2018-5156: Media recorder segmentation fault when track type is changed during capture

- CVE-2018-12363: Use-after-free when appending DOM nodes

- CVE-2018-12364: CSRF attacks through 307 redirects and NPAPI plugins

- CVE-2018-12365: Compromised IPC child process can list local filenames

- CVE-2018-12371: Integer overflow in Skia library during edge builder allocation

- CVE-2018-12366: Invalid data handling during QCMS transformations

- CVE-2018-12367: Timing attack mitigation of PerformanceNavigationTiming

- CVE-2018-12369: WebExtension security permission checks bypassed by embedded experiments

- CVE-2018-5187: Memory safety bugs fixed in Firefox 60 and Firefox ESR 60.1

- CVE-2018-5188: Memory safety bugs fixed in Firefox 60, Firefox ESR 60.1, and Firefox ESR 52.9

Other issues fixed :

- various stability and regression fixes

- do not disable system installed unsigned language packs (bmo#1464766)

Solution

Update the affected MozillaFirefox packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1098998

Plugin Details

Severity: High

ID: 110801

File Name: openSUSE-2018-676.nasl

Version: 1.7

Type: local

Agent: unix

Published: 6/29/2018

Updated: 1/19/2021

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:MozillaFirefox, p-cpe:/a:novell:opensuse:MozillaFirefox-branding-upstream, p-cpe:/a:novell:opensuse:MozillaFirefox-buildsymbols, p-cpe:/a:novell:opensuse:MozillaFirefox-debuginfo, p-cpe:/a:novell:opensuse:MozillaFirefox-debugsource, p-cpe:/a:novell:opensuse:MozillaFirefox-devel, p-cpe:/a:novell:opensuse:MozillaFirefox-translations-common, p-cpe:/a:novell:opensuse:MozillaFirefox-translations-other, cpe:/o:novell:opensuse:15.0, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 6/28/2018

Reference Information

CVE: CVE-2018-12359, CVE-2018-12360, CVE-2018-12361, CVE-2018-12362, CVE-2018-12363, CVE-2018-12364, CVE-2018-12365, CVE-2018-12366, CVE-2018-12367, CVE-2018-12369, CVE-2018-12371, CVE-2018-5156, CVE-2018-5187, CVE-2018-5188