PostgreSQL 9.3 < 9.3.23 / 9.4 < 9.4.18 / 9.5 < 9.5.13 / 9.6 < 9.6.9 / 10.3 Insecure ACL Remote Issue

Medium Nessus Plugin ID 110288

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of PostgreSQL installed on the remote host is 9.3.x prior to 9.3.23, 9.4.x prior to 9.4.18, 9.5.x prior to 9.5.13, or 9.6.x prior to 9.6.9, or 10.3.x. As such, it is potentially affected by Insecure ACL Remote Issue

Solution

Upgrade to PostgreSQL 9.3.23 / 9.4.18 / 9.5.13 / 9.6.9 / 10.4 or later.

See Also

https://www.postgresql.org/about/news/1851/

https://www.us-cert.gov/ncas/bulletins/SB18-134

Plugin Details

Severity: Medium

ID: 110288

File Name: postgresql_20181115.nasl

Version: 1.3

Type: local

Family: Databases

Published: 2018/06/01

Updated: 2018/08/16

Dependencies: 63346

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:P

CVSS v3.0

Base Score: 4.2

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2018/05/10

Vulnerability Publication Date: 2018/05/10

Reference Information

CVE: CVE-2018-1115

BID: 104285