CVE-2018-1115

MEDIUM

Description

postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog.pg_logfile_rotate() function doesn't follow the same ACLs than pg_rorate_logfile. If the adminpack is added to a database, an attacker able to connect to it could exploit this to force log rotation.

References

http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html

http://www.securityfocus.com/bid/104285

https://access.redhat.com/errata/RHSA-2018:2565

https://access.redhat.com/errata/RHSA-2018:2566

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1115

https://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=7b34740

https://security.gentoo.org/glsa/201810-08

Details

Source: MITRE

Published: 2018-05-10

Updated: 2020-09-09

Type: CWE-732

Risk Information

CVSS v2.0

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:P

Impact Score: 4.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3.0

Base Score: 9.1

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

Impact Score: 5.2

Exploitability Score: 3.9

Severity: CRITICAL