PostgreSQL 9.3.x < 9.3.22 / 9.4.x < 9.4.17 / 9.5.x < 9.5.12 / 9.6.x < 9.6.8 / 10.x < 10.3 Privilege Escalation Vulnerability

High Nessus Plugin ID 107226

Synopsis

The remote database server is affected a privilege escalation vulnerability.

Description

The version of PostgreSQL installed on the remote host is 9.3.x prior to 9.3.22, 9.4.x prior to 9.4.17, 9.5.x prior to 9.5.12, 9.6.x prior to 9.6.8, or 10.x prior to 10.3. It is, therefore, affected by a privilege escalation vulnerability.

Solution

Upgrade to PostgreSQL version 9.3.22 / 9.4.17 / 9.5.12 / 9.6.8 / 10.3 or later.

See Also

https://www.postgresql.org/about/news/1834/

https://www.postgresql.org/docs/current/static/release-9-3-22.html

https://www.postgresql.org/docs/current/static/release-9-4-17.html

https://www.postgresql.org/docs/current/static/release-9-5-12.html

https://www.postgresql.org/docs/current/static/release-9-6-8.html

https://www.postgresql.org/docs/current/static/release-10-3.html

Plugin Details

Severity: High

ID: 107226

File Name: postgresql_20180301.nasl

Version: 1.6

Type: local

Family: Databases

Published: 2018/03/08

Modified: 2018/09/17

Dependencies: 63346

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-1058

CVSSv2

Base Score: 9

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSSv3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2018/02/26

Vulnerability Publication Date: 2018/02/26

Reference Information

CVE: CVE-2018-1058

BID: 103221