CVE-2018-1058

MEDIUM

Description

A flaw was found in the way Postgresql allowed a user to modify the behavior of a query for other users. An attacker with a user account could use this flaw to execute code with the permissions of superuser in the database. Versions 9.3 through 10 are affected.

References

http://www.securityfocus.com/bid/103221

https://access.redhat.com/errata/RHSA-2018:2511

https://access.redhat.com/errata/RHSA-2018:2566

https://access.redhat.com/errata/RHSA-2018:3816

https://bugzilla.redhat.com/show_bug.cgi?id=1547044

https://usn.ubuntu.com/3589-1/

https://www.postgresql.org/about/news/1834/

Details

Source: MITRE

Published: 2018-03-02

Updated: 2019-03-25

Type: CWE-264

Risk Information

CVSS v2.0

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8

Severity: MEDIUM

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH