FreeBSD : PostgreSQL vulnerabilities (e3eeda2e-1d67-11e8-a2ec-6cc21735f730)

Medium Nessus Plugin ID 107112

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

The PostgreSQL project reports :

- CVE-2018-1058: Uncontrolled search path element in pg_dump and other client applications

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?521c69a9

http://www.nessus.org/u?22ef657d

Plugin Details

Severity: Medium

ID: 107112

File Name: freebsd_pkg_e3eeda2e1d6711e8a2ec6cc21735f730.nasl

Version: 3.6

Type: local

Published: 2018/03/02

Modified: 2018/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSSv3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:postgresql10-server, p-cpe:/a:freebsd:freebsd:postgresql93-server, p-cpe:/a:freebsd:freebsd:postgresql94-server, p-cpe:/a:freebsd:freebsd:postgresql95-server, p-cpe:/a:freebsd:freebsd:postgresql96-server, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/03/01

Vulnerability Publication Date: 2018/03/01

Reference Information

CVE: CVE-2018-1058