pfSense < 2.3 Multiple Vulnerabilities (SA-16_01 - SA-16_02)

critical Nessus Plugin ID 106499


The remote firewall host is affected by multiple vulnerabilities.


According to its self-reported version number, the remote pfSense install is prior to 2.3. It is, therefore, affected by multiple vulnerabilities.


Upgrade to pfSense version 2.3 or later.

See Also

Plugin Details

Severity: Critical

ID: 106499

File Name: pfsense_SA-16_02.nasl

Version: 1.13

Type: remote

Family: Firewalls

Published: 1/31/2018

Updated: 11/8/2019

Supported Sensors: Nessus

Risk Information


Risk Factor: High

Score: 7.4


Risk Factor: Critical

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2016-0799


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/1/2016

Vulnerability Publication Date: 4/1/2016

Exploitable With

Core Impact

Metasploit (pfSense authenticated graph status RCE)

Reference Information

CVE: CVE-2015-3197, CVE-2015-5300, CVE-2015-7973, CVE-2015-7974, CVE-2015-7975, CVE-2015-7976, CVE-2015-7977, CVE-2015-7978, CVE-2015-7979, CVE-2015-8138, CVE-2015-8139, CVE-2015-8140, CVE-2015-8158, CVE-2016-0702, CVE-2016-0703, CVE-2016-0704, CVE-2016-0705, CVE-2016-0777, CVE-2016-0778, CVE-2016-0797, CVE-2016-0798, CVE-2016-0799, CVE-2016-0800, CVE-2016-10709, CVE-2016-1879, CVE-2016-1882, CVE-2016-1885

BID: 77312, 80695, 80698, 80704, 80754, 81811, 81814, 81815, 81816, 81959, 81960, 81962, 81963, 82102, 82105, 82237, 83705, 83733, 83743, 83754, 83755, 83763, 83764

CERT: 583776, 718152

FreeBSD: SA-16:01.sctp, SA-16:02.ntp, SA-16:05.tcp, SA-16:07.openssh, SA-16:09.ntp, SA-16:11.openssl, SA-16:12.openssl, SA-16:15.sysarch