pfSense < 2.3 Multiple Vulnerabilities (SA-16_01 - SA-16_02)

High Nessus Plugin ID 106499


The remote firewall host is affected by multiple vulnerabilities.


According to its self-reported version number, the remote pfSense install is prior to 2.3. It is, therefore, affected by multiple vulnerabilities.


Upgrade to pfSense version 2.3 or later.

See Also

Plugin Details

Severity: High

ID: 106499

File Name: pfsense_SA-16_02.nasl

Version: $Revision: 1.6 $

Type: remote

Family: CGI abuses

Published: 2018/01/31

Modified: 2018/02/22

Dependencies: 106952

Risk Information

Risk Factor: High


Base Score: 9

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 10

Temporal Score: 9.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/04/01

Vulnerability Publication Date: 2016/04/01

Reference Information

CVE: CVE-2016-10709

OSVDB: 137161, 137162, 137163, 137164