PHP 5.6.x < 5.6.33 Multiple Vulnerabilities

medium Nessus Plugin ID 105771
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of PHP running on the remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 5.6.x prior to 5.6.33. It is, therefore, affected by multiple vulnerabilities :

- A potential infinite loop in gdImageCreateFromGifCtx.
(CVE-2018-5711)

- A reflected XSS in .phar 404 page exists due to improper validation of user-supplied input before returning it to users. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session. (CVE-2018-5712)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 5.6.33 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.6.33

Plugin Details

Severity: Medium

ID: 105771

File Name: php_5_6_33.nasl

Version: 1.9

Type: remote

Family: CGI abuses

Published: 1/12/2018

Updated: 11/8/2019

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2018-5712

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 1/4/2018

Vulnerability Publication Date: 1/4/2018

Reference Information

CVE: CVE-2018-5711, CVE-2018-5712