Debian DSA-4079-1 : poppler - security update

Medium Nessus Plugin ID 105623

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities were discovered in the poppler PDF rendering library, which could result in denial of service or the execution of arbitrary code if a malformed PDF file is processed.

Solution

Upgrade the poppler packages.

For the oldstable distribution (jessie), these problems have been fixed in version 0.26.5-2+deb8u2.

For the stable distribution (stretch), these problems have been fixed in version 0.48.0-2+deb9u1.

See Also

https://security-tracker.debian.org/tracker/source-package/poppler

https://packages.debian.org/source/jessie/poppler

https://packages.debian.org/source/stretch/poppler

https://www.debian.org/security/2018/dsa-4079

Plugin Details

Severity: Medium

ID: 105623

File Name: debian_DSA-4079.nasl

Version: 3.8

Type: local

Agent: unix

Published: 2018/01/08

Updated: 2019/03/15

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:poppler, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/01/07

Vulnerability Publication Date: 2017/06/02

Reference Information

CVE: CVE-2017-14517, CVE-2017-14518, CVE-2017-14519, CVE-2017-14520, CVE-2017-14975, CVE-2017-14976, CVE-2017-14977, CVE-2017-15565, CVE-2017-9406, CVE-2017-9408, CVE-2017-9775, CVE-2017-9776, CVE-2017-9865

DSA: 4079