MariaDB 10.2.x < 10.2.10 Multiple Vulnerabilities

high Nessus Plugin ID 105077
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote database server is affected by multiple vulnerabilities.


The version of MariaDB running on the remote host is 10.2.x prior to 10.2.10. It is, therefore, affected by multiple vulnerabilities.


Upgrade to MariaDB version 10.2.10 or later.

See Also

Plugin Details

Severity: High

ID: 105077

File Name: mariadb_10_2_10.nasl

Version: 1.6

Type: remote

Family: Databases

Published: 12/7/2017

Updated: 11/12/2019

Dependencies: mysql_version.nasl, mysql_login.nasl

Risk Information

CVSS Score Source: CVE-2017-15365


Risk Factor: Medium

Score: 5.9


Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Exploit Ease: No known exploits are available

Patch Publication Date: 10/31/2017

Vulnerability Publication Date: 10/31/2017

Reference Information

CVE: CVE-2017-3302, CVE-2017-3308, CVE-2017-3309, CVE-2017-3313, CVE-2017-3453, CVE-2017-3456, CVE-2017-3464, CVE-2017-3636, CVE-2017-3641, CVE-2017-3653, CVE-2017-10268, CVE-2017-10378, CVE-2017-10379, CVE-2017-10384, CVE-2017-15365

BID: 95527, 96162, 97725, 97742, 97776, 97831, 99736, 99767, 99810, 101375, 101390, 101406, 101415