CVE-2017-15365

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

sql/event_data_objects.cc in MariaDB before 10.1.30 and 10.2.x before 10.2.10 and Percona XtraDB Cluster before 5.6.37-26.21-3 and 5.7.x before 5.7.19-29.22-3 allows remote authenticated users with SQL access to bypass intended access restrictions and replicate data definition language (DDL) statements to cluster nodes by leveraging incorrect ordering of DDL replication and ACL checking.

References

https://access.redhat.com/errata/RHSA-2019:1258

https://bugzilla.redhat.com/show_bug.cgi?id=1524234

https://github.com/MariaDB/server/commit/0b5a5258abbeaf8a0c3a18c7e753699787fdf46e

https://lists.fedoraproject.org/archives/list/[email protected]/message/ELCZV46WIYSJ6VMC65GMNN3A3QDRUJGK/

https://mariadb.com/kb/en/library/mariadb-10130-release-notes/

https://mariadb.com/kb/en/library/mariadb-10210-release-notes/

https://www.debian.org/security/2018/dsa-4341

https://www.percona.com/blog/2017/10/30/percona-xtradb-cluster-5-6-37-26-21-3-is-now-available/

https://www.percona.com/doc/percona-xtradb-cluster/LATEST/release-notes/Percona-XtraDB-Cluster-5.7.19-29.22-3.html

Details

Source: MITRE

Published: 2018-01-25

Updated: 2019-10-03

Risk Information

CVSS v2

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8

Severity: MEDIUM

CVSS v3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.8

Severity: HIGH

Tenable Plugins

View all (4 total)

IDNameProductFamilySeverity
119040Debian DSA-4341-1 : mariadb-10.1 - security updateNessusDebian Local Security Checks
medium
106274Fedora 26 : 3:mariadb (2018-0d6a80f496)NessusFedora Local Security Checks
high
105451FreeBSD : MariaDB -- unspecified vulnerability (b7d89082-e7c0-11e7-ac58-b499baebfeaf)NessusFreeBSD Local Security Checks
high
105077MariaDB 10.2.x < 10.2.10 Multiple VulnerabilitiesNessusDatabases
high