Cisco IOS XE Software Plug-and-Play PKI API Certificate Validation Vulnerability

Medium Nessus Plugin ID 103676


The remote device is missing a vendor-supplied security patch.


According to its self-reported version, the Cisco IOS XE Software is affected by one or more vulnerabilities. Please see the included Cisco BIDs and the Cisco Security Advisory for more information.


Upgrade to the relevant fixed version referenced in Cisco bug ID(s) CSCvc33171.

See Also

Plugin Details

Severity: Medium

ID: 103676

File Name: cisco-sa-20170927-pnp-ios_xe.nasl

Version: 1.5

Type: local

Family: CISCO

Published: 2017/10/06

Modified: 2018/03/01

Dependencies: 67217

Risk Information

Risk Factor: Medium


Base Score: 4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:N


Base Score: 4.8

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:/o:cpe:/o:cisco:ios_xe

Required KB Items: Host/Cisco/IOS-XE/Version

Patch Publication Date: 2017/09/27

Vulnerability Publication Date: 2017/09/27

Reference Information

CVE: CVE-2017-12228

BID: 101065

OSVDB: 166247


IAVA: 2017-A-0286

CISCO-SA: cisco-sa-20170927-pnp