SUSE SLES11 Security Update : liblouis (SUSE-SU-2017:2590-1)

Medium Nessus Plugin ID 103564


The remote SUSE host is missing one or more security updates.


This update for liblouis fixes several issues. These security issues were fixed :

- CVE-2017-13739: Prevent heap-based buffer overflow in the function resolveSubtable() that could have caused DoS or remote code execution (bsc#1056101)

- CVE-2017-13740: Prevent stack-based buffer overflow in the function parseChars() that could have caused DoS or possibly unspecified other impact (bsc#1056097) ()

- CVE-2017-13741: Prevent use-after-free in function compileBrailleIndicator() that allowed to cause remote DoS (bsc#1056095)

- CVE_2017-13742: Prevent stack-based buffer overflow in function includeFile that allowed to cause remote DoS (bsc#1056093).

- CVE-2017-13743: Prevent buffer overflow triggered in the function _lou_showString() that allowed to cause remote DoS (bsc#1056090)

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Server 11-SP4:zypper in -t patch slessp4-liblouis-13291=1

SUSE Linux Enterprise Debuginfo 11-SP4:zypper in -t patch dbgsp4-liblouis-13291=1

To bring your system up-to-date, use 'zypper patch'.

See Also

Plugin Details

Severity: Medium

ID: 103564

File Name: suse_SU-2017-2590-1.nasl

Version: $Revision: 3.3 $

Type: local

Agent: unix

Published: 2017/09/29

Modified: 2018/01/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND


Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:liblouis, p-cpe:/a:novell:suse_linux:liblouis0, p-cpe:/a:novell:suse_linux:python-louis, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/09/28

Reference Information

CVE: CVE-2017-13739, CVE-2017-13740, CVE-2017-13741, CVE-2017-13743

OSVDB: 164252, 164253, 164254, 164256