SUSE SLES11 Security Update : java-1_7_0-ibm (SUSE-SU-2017:1384-1)

critical Nessus Plugin ID 100375
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for java-1_7_0-ibm fixes the following issues: Version update to 7.0-10.5 bsc#1038505

- CVE-2016-9840: zlib: Out-of-bounds pointer arithmetic in inftrees.c

- CVE-2016-9841: zlib: Out-of-bounds pointer arithmetic in inffast.c

- CVE-2016-9842: zlib: Undefined left shift of negative number

- CVE-2016-9843: zlib: Big-endian out-of-bounds pointer

- CVE-2017-1289: IBM JDK: XML External Entity Injection (XXE) error when processing XML data

- CVE-2017-3509: OpenJDK: improper re-use of NTLM authenticated connections

- CVE-2017-3511: OpenJDK: untrusted extension directories search path in Launcher

- CVE-2017-3539: OpenJDK: MD5 allowed for jar verification

- CVE-2017-3533: OpenJDK: newline injection in the FTP client

- CVE-2017-3544: OpenJDK: newline injection in the SMTP client

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Server 11-SP3-LTSS:zypper in -t patch slessp3-java-1_7_0-ibm-13124=1

SUSE Linux Enterprise Point of Sale 11-SP3:zypper in -t patch sleposp3-java-1_7_0-ibm-13124=1

To bring your system up-to-date, use 'zypper patch'.

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1038505

https://www.suse.com/security/cve/CVE-2016-9840/

https://www.suse.com/security/cve/CVE-2016-9841/

https://www.suse.com/security/cve/CVE-2016-9842/

https://www.suse.com/security/cve/CVE-2016-9843/

https://www.suse.com/security/cve/CVE-2017-1289/

https://www.suse.com/security/cve/CVE-2017-3509/

https://www.suse.com/security/cve/CVE-2017-3511/

https://www.suse.com/security/cve/CVE-2017-3533/

https://www.suse.com/security/cve/CVE-2017-3539/

https://www.suse.com/security/cve/CVE-2017-3544/

http://www.nessus.org/u?2813b030

Plugin Details

Severity: Critical

ID: 100375

File Name: suse_SU-2017-1384-1.nasl

Version: 3.11

Type: local

Agent: unix

Published: 5/24/2017

Updated: 1/19/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: High

Score: 8.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:java-1_7_0-ibm, p-cpe:/a:novell:suse_linux:java-1_7_0-ibm-alsa, p-cpe:/a:novell:suse_linux:java-1_7_0-ibm-devel, p-cpe:/a:novell:suse_linux:java-1_7_0-ibm-jdbc, p-cpe:/a:novell:suse_linux:java-1_7_0-ibm-plugin, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 5/23/2017

Vulnerability Publication Date: 4/24/2017

Reference Information

CVE: CVE-2016-9840, CVE-2016-9841, CVE-2016-9842, CVE-2016-9843, CVE-2017-1289, CVE-2017-3509, CVE-2017-3511, CVE-2017-3533, CVE-2017-3539, CVE-2017-3544