MySQL Server 5.5.x <= 5.5.26 / 5.1.x <= 5.1.64 Multiple Unspecified Vulnerabilities

high Log Correlation Engine Plugin ID 801168

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL 5.5 installed on the remote host is earlier than 5.5.27. As such, it is reportedly affected by the following vulnerabilities:

- An exploitable vulnerability which allows successful authenticated network attacks via multiple protocols. In some cases it can cause a Denial-of-Service or result in execution of arbitrary code.

Solution

Upgrade to MySQL Community Server 5.5.27 / 5.1.65 later.

See Also

http://www.oracle.com/technetwork/topics/security/cpuoct2012-1515893.html

http://www.oracle.com/technetwork/topics/security/cpuoct2012verbose-1515934.html

Plugin Details

Severity: High

ID: 801168

Family: Database

Published: 10/19/2012

Updated: 10/19/2012

Nessus ID: 62638, 62641

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 10/16/2012

Vulnerability Publication Date: 10/16/2012

Reference Information

CVE: CVE-2012-3150, CVE-2012-3158, CVE-2012-3163, CVE-2012-3197, CVE-2012-3144, CVE-2012-3147, CVE-2012-3149

BID: 55990, 56017, 56021, 56036, 56006, 56008, 56022