PHP < 4.3.10 / 5.0.3 Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 801104

Synopsis

The remote host is vulnerable to a script injection attack.

Description

The remote host is running a version of PHP which is older than 5.0.3 or 4.3.10.
The remote version of this software is vulnerable to various security issues that may, under certain circumstances, allow attackers to execute arbitrary code on the remote host, provided that they can pass arbitrary data to some functions or bypass safe_mode.

Solution

Upgrade to PHP 5.0.3 or 4.3.10 or higher.

See Also

http://.php.net/ChangeLog-5.php#5.0.3

Plugin Details

Severity: High

ID: 801104

File Name: 801104.prm

Family: Web Servers

Nessus ID: 15973

Risk Information

Risk Factor: High

CVSSv2

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Reference Information

CVE: CVE-2004-1018, CVE-2004-1019, CVE-2004-1020, CVE-2004-1063, CVE-2004-1064, CVE-2004-1065

BID: 11981, 11992, 12045, 11964