PHP < 4.4.9 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 801083


The remote web server uses a version of PHP that is affected by multiple issues.


According to its banner, the version of PHP installed on the remote host is older than 4.4.9. Such versions address several security issues, including :

- An update of PCRE to version 7.7.
- An overflow in memnstr().
- A crash in imageloadfont when an invalid font is given.
- An open_basedir handling issue in the curl extension.
- 'mbstring.func_overload' set in '.htaccess' becomes global. Note that the release announcement states this will be the last release for the PHP 4.4 series.


Upgrade to version 4.4.9 or higher.

See Also

Plugin Details

Severity: High

ID: 801083

Family: Web Servers

Nessus ID: 32123, 33849

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Reference Information

CVE: CVE-2008-2051, CVE-2008-3658, CVE-2008-3660, CVE-2008-0674, CVE-2007-4850, CVE-2008-2050

BID: 30649, 31612, 33542