PHP < 4.4.9 Multiple Vulnerabilities
High Log Correlation Engine Plugin ID 801083
SynopsisThe remote web server uses a version of PHP that is affected by multiple issues.
DescriptionAccording to its banner, the version of PHP installed on the remote host is older than 4.4.9. Such versions address several security issues, including :
- An update of PCRE to version 7.7.
- An overflow in memnstr().
- A crash in imageloadfont when an invalid font is given.
- An open_basedir handling issue in the curl extension.
- 'mbstring.func_overload' set in '.htaccess' becomes global. Note that the release announcement states this will be the last release for the PHP 4.4 series.
SolutionUpgrade to version 4.4.9 or higher.