openSUSE Security Update : apache2-mod_php5 (openSUSE-SU-2010:0599-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

PHP was updated to version 5.3.3 to fix serveral security issues.

(CVE-2010-0397, CVE-2010-1860, CVE-2010-1862, CVE-2010-1864,
CVE-2010-1866, CVE-2010-1914, CVE-2010-1915, CVE-2010-1917,
CVE-2010-2093, CVE-2010-2094, CVE-2010-2097, CVE-2010-2100,
CVE-2010-2101, CVE-2010-2190, CVE-2010-2191, CVE-2010-2225,
CVE-2010-2531, CVE-2010-2950, CVE-2010-3062, CVE-2010-3063,
CVE-2010-3064, CVE-2010-3065)

See also :

http://lists.opensuse.org/opensuse-updates/2010-09/msg00013.html
https://bugzilla.novell.com/show_bug.cgi?id=588975
https://bugzilla.novell.com/show_bug.cgi?id=604315
https://bugzilla.novell.com/show_bug.cgi?id=604652
https://bugzilla.novell.com/show_bug.cgi?id=604654
https://bugzilla.novell.com/show_bug.cgi?id=604656
https://bugzilla.novell.com/show_bug.cgi?id=605097
https://bugzilla.novell.com/show_bug.cgi?id=605100
https://bugzilla.novell.com/show_bug.cgi?id=609763
https://bugzilla.novell.com/show_bug.cgi?id=609766
https://bugzilla.novell.com/show_bug.cgi?id=609768
https://bugzilla.novell.com/show_bug.cgi?id=609769
https://bugzilla.novell.com/show_bug.cgi?id=612555
https://bugzilla.novell.com/show_bug.cgi?id=612556
https://bugzilla.novell.com/show_bug.cgi?id=616232
https://bugzilla.novell.com/show_bug.cgi?id=619483
https://bugzilla.novell.com/show_bug.cgi?id=619486
https://bugzilla.novell.com/show_bug.cgi?id=619487
https://bugzilla.novell.com/show_bug.cgi?id=619489
https://bugzilla.novell.com/show_bug.cgi?id=633932
https://bugzilla.novell.com/show_bug.cgi?id=633934
https://bugzilla.novell.com/show_bug.cgi?id=636923

Solution :

Update the affected apache2-mod_php5 packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)