openSUSE Security Update : cobbler (openSUSE-SU-2012:0557-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

Specially crafted YAML could allow attackers to execute arbitrary code
due to the use of yaml.load instead of yaml.safe_load.

Cobbler-web was prone to Cross-Site-Request-Forgery (CSRF)

See also :

http://lists.opensuse.org/opensuse-updates/2012-04/msg00059.html
https://bugzilla.novell.com/show_bug.cgi?id=757062
https://bugzilla.novell.com/show_bug.cgi?id=757316
https://bugzilla.novell.com/show_bug.cgi?id=757479

Solution :

Update the affected cobbler packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 74609 ()

Bugtraq ID:

CVE ID: CVE-2011-4952
CVE-2011-4953
CVE-2011-4954

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now