This script is Copyright (C) 2010-2017 Tenable Network Security, Inc.
The remote web server is affected by multiple vulnerabilities.
According to its banner, the version of Apache 2.0.x running on the
remote host is prior to 2.0.64. It is, therefore, affected by the
following vulnerabilities :
- An unspecified error exists in the handling of requests
without a path segment. (CVE-2010-1452)
- Several modules, including 'mod_deflate', are
vulnerable to a denial of service attack as the
server can be forced to utilize CPU time compressing
a large file after client disconnect. (CVE-2009-1891)
- An unspecified error exists in 'mod_proxy' related to
filtration of authentication credentials.
- A NULL pointer dereference issue exists in
'mod_proxy_ftp' in some error handling paths.
- An error exists in 'mod_ssl' making the server
vulnerable to the TLC renegotiation prefix injection
- An error exists in the handling of subrequests such
that the parent request headers may be corrupted.
- An error exists in 'mod_proxy_http' when handling excessive
interim responses making it vulnerable to a denial of
service attack. (CVE-2008-2364)
- An error exists in 'mod_isapi' that allows the module
to be unloaded too early, which leaves orphaned callback
- An error exists in 'mod_proxy_ftp' when wildcards are
in an FTP URL, which allows for cross-site scripting
Note that the remote web server may not actually be affected by these
vulnerabilities. Nessus did not try to determine whether the affected
modules are in use or to check for the issues themselves.
See also :
Upgrade to Apache version 2.0.64 or later. Alternatively, ensure that
the affected modules are not in use.
Risk factor :
High / CVSS Base Score : 7.5
CVSS Temporal Score : 6.8
Public Exploit Available : true
Family: Web Servers
Nessus Plugin ID: 50069 (apache_2_0_64.nasl)
Get Nessus Professional to scan unlimited IPs, run compliance checks & moreBuy Nessus Professional Now