openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-2039)

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

- the CURL module lacked checks for control characters
(CVE-2006-2563))

- str_repeat() contained an integer overflow

- ext/wddx contained a buffer overflow

- memory_limit() lacked checks for integer overflows

- a bug in sscanf() could potentially be exploited to
execute arbitrary code (CVE-2006-4020)

- an uninitialized varable caused apache to crash during
startup

- corrupt gif images could crash php

Solution :

Update the affected apache2-mod_php5 packages.

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 27146 ()

Bugtraq ID:

CVE ID: CVE-2006-2563
CVE-2006-4020

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now