CVE-2006-2563

low
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The cURL library (libcurl) in PHP 4.4.2 and 5.1.4 allows attackers to bypass safe mode and read files via a file:// request containing null characters.

References

http://secunia.com/advisories/20337

http://secunia.com/advisories/21050

http://secunia.com/advisories/21847

http://secunia.com/advisories/22039

http://securityreason.com/achievement_securityalert/39

http://securityreason.com/securityalert/959

http://securitytracker.com/id?1016175

http://www.mandriva.com/security/advisories?name=MDKSA-2006:122

http://www.novell.com/linux/security/advisories/2006_22_sr.html

http://www.novell.com/linux/security/advisories/2006_52_php.html

http://www.securityfocus.com/bid/18116

http://www.vupen.com/english/advisories/2006/2055

https://exchange.xforce.ibmcloud.com/vulnerabilities/26764

Details

Source: MITRE

Published: 2006-05-29

Updated: 2017-07-20

Risk Information

CVSS v2

Base Score: 2.1

Vector: AV:L/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 3.9

Severity: LOW

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
29374SuSE 10 Security Update : PHP5 (ZYPP Patch Number 2102)NessusSuSE Local Security Checks
medium
27897Ubuntu 5.04 / 5.10 / 6.06 LTS : php4, php5 vulnerabilities (USN-320-1)NessusUbuntu Local Security Checks
high
27146openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-2039)NessusSuSE Local Security Checks
medium
22268PHP < 4.4.3 / 5.1.4 Multiple VulnerabilitiesNessusCGI abuses
high
22053Mandrake Linux Security Advisory : php (MDKSA-2006:122)NessusMandriva Local Security Checks
critical