CVE-2018-1447

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The GSKit (IBM Spectrum Protect 7.1 and 7.2) and (IBM Spectrum Protect Snapshot 4.1.3, 4.1.4, and 4.1.6) CMS KDB logic fails to salt the hash function resulting in weaker than expected protection of passwords. A weak password may be recovered. Note: After update the customer should change password to ensure the new password is stored more securely. Products should encourage customers to take this step as a high priority action. IBM X-Force ID: 139972.

References

http://www.ibm.com/support/docview.wss?uid=swg22014669

http://www.ibm.com/support/docview.wss?uid=swg22014957

http://www.ibm.com/support/docview.wss?uid=swg22015066

http://www.ibm.com/support/docview.wss?uid=swg22015071

http://www.securityfocus.com/bid/104511

http://www.securitytracker.com/id/1041012

https://exchange.xforce.ibmcloud.com/vulnerabilities/139972

Details

Source: MITRE

Published: 2018-04-04

Updated: 2019-10-03

Type: CWE-916

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 2.2

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:ibm:spectrum_protect_for_space_management:*:*:*:*:*:vmware:*:* versions from 7.1.0.0 to 7.1.8.1 (inclusive)

cpe:2.3:a:ibm:spectrum_protect_for_space_management:*:*:*:*:*:vmware:*:* versions from 8.1.0.0 to 8.1.4.0 (inclusive)

cpe:2.3:a:ibm:spectrum_protect_for_virtual_environments:*:*:*:*:*:vmware:*:* versions from 7.1.0.0 to 7.1.8.0 (inclusive)

cpe:2.3:a:ibm:spectrum_protect_for_virtual_environments:*:*:*:*:*:vmware:*:* versions from 8.1.0.0 to 8.1.4.0 (inclusive)

Configuration 2

OR

cpe:2.3:a:ibm:spectrum_protect_snapshot:*:*:*:*:*:vmware:*:* versions from 4.1.0.0 to 4.1.6.3 (inclusive)

Tenable Plugins

View all (1 total)

IDNameProductFamilySeverity
144773IBM HTTP Server 7.0.0.0 <= 7.0.0.43 / 8.0.0.0 <= 8.0.0.14 / 8.5.0.0 < 8.5.5.14 / 9.0.0.0 < 9.0.0.8 Multiple Vulnerabilities (569301)NessusWeb Servers
critical