CVE-2007-1286

MEDIUM

Description

Integer overflow in PHP 4.4.4 and earlier allows remote context-dependent attackers to execute arbitrary code via a long string to the unserialize function, which triggers the overflow in the ZVAL reference counter.

References

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01056506

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01086137

http://rhn.redhat.com/errata/RHSA-2007-0154.html

http://rhn.redhat.com/errata/RHSA-2007-0155.html

http://rhn.redhat.com/errata/RHSA-2007-0163.html

http://secunia.com/advisories/24419

http://secunia.com/advisories/24606

http://secunia.com/advisories/24910

http://secunia.com/advisories/24924

http://secunia.com/advisories/24941

http://secunia.com/advisories/24945

http://secunia.com/advisories/25025

http://secunia.com/advisories/25062

http://secunia.com/advisories/25423

http://secunia.com/advisories/25445

http://secunia.com/advisories/25850

http://security.gentoo.org/glsa/glsa-200703-21.xml

http://security.gentoo.org/glsa/glsa-200705-19.xml

http://www.debian.org/security/2007/dsa-1282

http://www.debian.org/security/2007/dsa-1283

http://www.mandriva.com/security/advisories?name=MDKSA-2007:087

http://www.mandriva.com/security/advisories?name=MDKSA-2007:088

http://www.osvdb.org/32771

http://www.php-security.org/MOPB/MOPB-04-2007.html

http://www.securityfocus.com/archive/1/466166/100/0/threaded

http://www.securityfocus.com/bid/22765

http://www.trustix.org/errata/2007/0009/

http://www.vupen.com/english/advisories/2007/1991

http://www.vupen.com/english/advisories/2007/2374

https://exchange.xforce.ibmcloud.com/vulnerabilities/32796

https://issues.rpath.com/browse/RPL-1268

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11575

Details

Source: MITRE

Published: 2007-03-06

Updated: 2018-10-16

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:php:php:*:*:*:*:*:*:*:* versions up to 4.4.4 (inclusive)

Tenable Plugins

View all (10 total)

IDNameProductFamilySeverity
78215F5 Networks BIG-IP : Multiple PHP vulnerabilities (SOL7859)NessusF5 Networks Local Security Checks
high
67471Oracle Linux 3 / 4 : php (ELSA-2007-0155)NessusOracle Linux Local Security Checks
high
25340GLSA-200705-19 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
25100Debian DSA-1283-1 : php5 - several vulnerabilitiesNessusDebian Local Security Checks
high
25099Debian DSA-1282-1 : php4 - several vulnerabilitiesNessusDebian Local Security Checks
high
25068RHEL 3 / 4 : php (RHSA-2007:0155)NessusRed Hat Local Security Checks
high
25067RHEL 2.1 : php (RHSA-2007:0154)NessusRed Hat Local Security Checks
medium
25043CentOS 3 / 4 : php (CESA-2007:0155)NessusCentOS Local Security Checks
high
24906PHP < 4.4.5 Multiple VulnerabilitiesNessusCGI abuses
high
24887GLSA-200703-21 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical