phpMyAdmin setup.php Verbose Server Name XSS (PMASA-2010-7)

This script is Copyright (C) 2010-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server contains a PHP application that has a cross-
site scripting vulnerability.

Description :

The setup script included with the version of phpMyAdmin installed on
the remote host does not properly sanitize user-supplied input to the
'verbose server name' field.

A remote attacker could exploit this by tricking a user into
executing arbitrary script code.

See also :

http://www.phpmyadmin.net/home_page/security/PMASA-2010-7.php

Solution :

Upgrade to phpMyAdmin 3.3.7 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)

Family: CGI abuses : XSS

Nessus Plugin ID: 49142 ()

Bugtraq ID:

CVE ID: CVE-2010-3263