Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Apache HTTP Server 2.2.x < 2.2.32 Multiple Vulnerabilities



The remote web server is missing an Apache HTTP Server patch update.


The version of Apache HTTP Server 2.2 installed on the remote host is prior to 2.2.32 and is affected by multiple vulnerabilities :

- A remote proxy manipulation vulnerability exists related to missing protection against RFC 3875 section 4.1.18 namespace conflicts. The issue is triggered when handling requests containing 'Proxy' HTTP headers, as these may be stored in the HTTP_PROXY environment variable also commonly used to configure an outbound HTTP proxy for CGI applications. With a specially crafted request, a remote attacker can specify an arbitrary HTTP proxy server to be used by CGI applications relying on the HTTP_PROXY environment variable. (CVE-2016-5387) - A flaw exists that is triggered when handling whitespace patterns in User-Agent headers. This may allow a remote attacker to use a specially crafted User-Agent header to cause the program to incorrectly handle sequences of requests, potentially interpreting responses incorrectly and polluting the cache, or disclosing content from one request to a second downstream user-agent. (CVE-2016-8743)


Upgrade to Apache HTTP Server version 2.2.32 or later.