Apache 2.2.x < 2.2.32 Multiple Vulnerabilities (httpoxy)

high Nessus Plugin ID 96450
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of Apache running on the remote host is 2.2.x prior to 2.2.32. It is, therefore, affected by the following vulnerabilities :

- The Apache HTTP Server is affected by a man-in-the-middle vulnerability known as 'httpoxy' due to a failure to properly resolve namespace conflicts in accordance with RFC 3875 section 4.1.18. The HTTP_PROXY environment variable is set based on untrusted user data in the 'Proxy' header of HTTP requests. The HTTP_PROXY environment variable is used by some web client libraries to specify a remote proxy server. An unauthenticated, remote attacker can exploit this, via a crafted 'Proxy' header in an HTTP request, to redirect an application's internal HTTP traffic to an arbitrary proxy server where it may be observed or manipulated.
(CVE-2016-5387)

- A flaw exists due to improper handling of whitespace patterns in user-agent headers. An unauthenticated, remote attacker can exploit this, via a specially crafted user-agent header, to cause the program to incorrectly process sequences of requests, resulting in interpreting responses incorrectly, polluting the cache, or disclosing the content from one request to a second downstream user-agent. (CVE-2016-8743)

- A CRLF injection allowing HTTP response splitting attacks for sites which use mod_userdir (CVE-2016-4975)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache version 2.2.32 or later.

Note that the 'httpoxy' vulnerability can be mitigated by applying the workarounds or patches as referenced in the vendor advisory asf-httpoxy-response.txt.

See Also

https://httpd.apache.org/dev/dist/Announcement2.2.html

http://httpd.apache.org/security/vulnerabilities_22.html

https://github.com/apache/httpd/blob/2.2.x/CHANGES

https://www.apache.org/security/asf-httpoxy-response.txt

https://httpoxy.org

Plugin Details

Severity: High

ID: 96450

File Name: apache_2_2_32.nasl

Version: 1.9

Type: remote

Family: Web Servers

Published: 1/12/2017

Updated: 3/27/2019

Dependencies: apache_http_version.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2016-5387

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 5.1

Temporal Score: 3.8

Vector: AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 1/13/2017

Vulnerability Publication Date: 7/18/2016

Reference Information

CVE: CVE-2016-4975, CVE-2016-5387, CVE-2016-8743

BID: 91816, 95077, 105093

CERT: 797896