Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Apache Traffic Server 5.1.x < 5.1.1 Multiple Vulnerabilities (POODLE)

Medium

Synopsis

The remote caching server is outdated and affected by multiple vulnerabilities.

Description

Apache Traffic Server versions 5.x prior to 5.1.2 are affected by the following vulnerabilities :

- A man-in-the-middle (MitM) information disclosure vulnerability exists which is known as POODLE. The vulnerability is due to the way SSL 3.0 handles padding bytes when decrypting messages encrypted using block ciphers in cipher block chaining (CBC) mode. MitM attackers can decrypt a selected byte of a cipher text in as few as 256 tries if they are able to force a victim application to repeatedly send the same data over newly created SSL 3.0 connections. (CVE-2014-3566) - A flaw exists that is triggered when using CONNECT to apply remaps. This may allow an attacker to enable the product to function as an open relay. (CVE-2014-3624)

Solution

Upgrade to Apache Traffic Server 5.1.1 or later.