Apache Traffic Server 5.1.x < 5.1.1 Multiple Vulnerabilities (POODLE)

Medium Nessus Plugin ID 80918


The remote caching server is affected by multiple vulnerabilities.


According to its banner, the version of Apache Traffic Server running on the remote host is 5.1.x prior to 5.1.1. It is, therefore, affected by the following vulnerabilities :

- A man-in-the-middle (MitM) information disclosure vulnerability known as POODLE. The vulnerability is due to the way SSL 3.0 handles padding bytes when decrypting messages encrypted using block ciphers in cipher block chaining (CBC) mode. MitM attackers can decrypt a selected byte of a cipher text in as few as 256 tries if they are able to force a victim application to repeatedly send the same data over newly created SSL 3.0 connections. (CVE-2014-3566)

- A flaw exists in the remap logic which may allow an open relay to be enabled. (CVE-2014-3624)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Traffic Server 5.1.1 or later.

See Also






Plugin Details

Severity: Medium

ID: 80918

File Name: apache_traffic_server_511.nasl

Version: $Revision: 1.8 $

Type: remote

Family: Web Servers

Published: 2015/01/22

Modified: 2016/05/24

Dependencies: 58592

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:TF/RC:UR

Vulnerability Information

CPE: cpe:/a:apache:traffic_server

Required KB Items: www/apache_traffic_server

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/11/01

Vulnerability Publication Date: 2014/10/14

Reference Information

CVE: CVE-2014-3566, CVE-2014-3624

BID: 70574

OSVDB: 113251

CERT: 577193