Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Squid 3.2.x < 3.2.14 / 3.3.x < 3.3.14 / 3.4.x < 3.4.13 / 3.5.x < 3.5.4 X.509 Certificate Validation Vulnerability

Medium

Synopsis

The remote proxy server is affected by a X.509 certificate validation vulnerability.

Description

Squid 3.2.x before 3.2.14, 3.3.x before 3.3.14, 3.4.x before 3.4.13, and 3.5.x before 3.5.4, when configured with client-first SSL-bump, does not properly validate the domain or hostname fields of X.509 certificates, which allows man-in-the-middle attackers to spoof SSL servers via a valid certificate.

Solution

Upgrade to Squid version 3.2.14 / 3.3.14 / 3.4.13 / 3.5.4 or later.