Squid 3.2 < 3.5.4 Incorrect X509 Server Certificate Validation Vulnerability

Medium Nessus Plugin ID 83529


The remote proxy server may be affected by a certificate validation vulnerability.


According to its banner, the version of Squid running on the remote host is 3.2 prior to 3.2.14 / 3.3.14 / 3.4.13 / 3.5.4. It is, therefore, potentially affected by a flaw related to certificate validation due to the server hostname not being verified as matching a the domain name in the certificate Subject's Common Name (CN) or the SubjectAltName fields. A man-in-the-middle attacker, using a crafted certificate, can utilize this to spoof a TLS/SSL server, thus allowing the disclosure or manipulation of intercepted data. Note that this flaw is exploitable only if Squid is configured to perform SSL Bumping with the 'client-first' or 'bump' mode of operation.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number. The patch released to address the issue does not update the version in the banner. If the patch has been applied properly, and the service has been restarted, consider this to be a false positive.


Upgrade to Squid versions 3.2.14 / 3.3.14 / 3.4.13 / 3.5.4, or apply the vendor-supplied patch.

See Also




Plugin Details

Severity: Medium

ID: 83529

File Name: squid_3_5_4.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Firewalls

Published: 2015/05/19

Modified: 2015/05/20

Dependencies: 49692

Risk Information

Risk Factor: Medium


Base Score: 5.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: www/squid, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/05/01

Vulnerability Publication Date: 2015/05/01

Reference Information

CVE: CVE-2015-3455

BID: 74438

OSVDB: 121513