Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Samba 4.x < 4.0.24 / 4.1.x < 4.1.16 / 4.2.x < 4.2rc4 UF_SERVER_TRUST_ACCOUNT AD DC Privilege Escalation

High

Synopsis

The remote version of Samba is outdated and affected by a privilege escalation vulnerability.

Description

The version of Samba on the remote host is 4.x prior to 4.0.24, 4.1.x prior to 4.1.16, or 4.2.x prior to 4.2rc4 and is affected by a flaw in the Active Directory Domain Controller (AD DC) component due to a failure to implement a required check on the 'UF_SERVER_TRUST_ACCOUNT' bit of the 'userAccountControl' attributes. This vulnerability could allow a remote, authenticated attacker to elevate privileges.

Solution

Upgrade to 4.0.24 / 4.1.16 / 4.2rc4 or later.