Samba 4.x < 4.0.24 / 4.1.16 UF_SERVER_TRUST_ACCOUNT AD DC Privilege Escalation

High Nessus Plugin ID 80916


The remote Samba server is affected by a privilege escalation vulnerability.


According to its banner, the version of Samba on the remote host is 4.x prior to 4.0.24 / 4.1.16. It is, therefore, affected by a flaw in the Active Directory Domain Controller (AD DC) component due to a failure to implement a required check on the 'UF_SERVER_TRUST_ACCOUNT' bit of the 'userAccountControl' attributes. This vulnerability could allow a remote, authenticated attacker to elevate privileges.

Note that this issue only affects Samba installations acting as Active Directory Domain Controllers that allow delegation for the creation of user or computer accounts.

Also note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Install the patch referenced in the project's advisory or upgrade to 4.0.24 / 4.1.16 or later.

Alternatively, as a workaround, do not delegate permission to create users or computers to entities other than Domain Administrators.

See Also

Plugin Details

Severity: High

ID: 80916

File Name: samba_4_1_16.nasl

Version: $Revision: 1.8 $

Type: remote

Family: Misc.

Published: 2015/01/22

Modified: 2016/06/16

Dependencies: 10785

Risk Information

Risk Factor: High


Base Score: 8.5

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/01/15

Vulnerability Publication Date: 2015/01/15

Reference Information

CVE: CVE-2014-8143

BID: 72278

OSVDB: 117132