Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

VLC Media Player < 2.0.2 RCE

High

Synopsis

The remote host contains an application that is vulnerable to a buffer overflow vulnerability

Description

The remote host is running VLC 2.x prior to 2.0.2 and is affected by a heap-based buffer overflow vulnerability. An error exists in the function 'Ogg_DecodePacket' in the file 'modules/demux/ogg.c' that does not properly validate input and can allow a heap-based buffer overflow. Opening a specially crafted file can result in the execution of arbitrary code.

Solution

Upgrade to VLC Media Player version 2.0.2 or later.