VLC Media Player < 2.0.2 Ogg_DecodePacket Function OGG File Handling Overflow

High Nessus Plugin ID 60049


The remote Windows host contains a media player that is affected by a buffer overflow vulnerability.


The version of VLC media player installed on the remote host is earlier than 2.0.2. It is, therefore, reportedly affected by a heap- based buffer overflow vulnerability.

An error exists in the function 'Ogg_DecodePacket' in the file 'modules/demux/ogg.c' that does not properly validate input and could allow a heap-based buffer overflow. Opening a specially crafted file can result in the execution of arbitrary code.


Upgrade to VLC Media Player version 2.0.2 or later. Alternatively, remove any affected plugin files from VLC's plugins directory.

See Also





Plugin Details

Severity: High

ID: 60049

File Name: vlc_2_0_2.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2012/07/19

Modified: 2014/11/07

Dependencies: 31852

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: SMB/VLC/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/05/02

Vulnerability Publication Date: 2012/04/30

Reference Information

CVE: CVE-2012-3377

BID: 54345

OSVDB: 83615