Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Samba 3.0.29 - 3.2.4 Potential Memory Disclosure

Medium

Synopsis

The remote Samba server may be affected by an information disclosure vulnerability.

Description

According to its banner, the version of the Samba server on the remote host is between 3.0.29 and 3.2.4 inclusive. Such versions reportedly can potentially leak arbitrary memory contents of the 'smbd' process due to a missing bounds check on client-generated offsets of secondary 'trans', 'trans2', and 'nttrans' requests.

Solution

Upgrade to version 3.2.5 / 3.0.33 or higher or apply the appropriate patch referenced in the project's advisory.