Samba 3.0.29 - 3.2.4 Potential Memory Disclosure

Medium Nessus Plugin ID 34993


The remote Samba server may be affected by an information disclosure vulnerability.


According to its banner, the version of the Samba server on the remote host is between 3.0.29 and 3.2.4 inclusive. Such versions reportedly can potentially leak arbitrary memory contents of the 'smbd' process due to a missing bounds check on client-generated offsets of secondary 'trans', 'trans2', and 'nttrans' requests.

Note that Nessus has not actually tried to exploit this issue or determine if the fix has been applied.


Upgrade to Samba version 3.2.5 / 3.0.33 or later or apply the appropriate patch referenced in the project's advisory.

See Also

Plugin Details

Severity: Medium

ID: 34993

File Name: samba_3_2_5.nasl

Version: $Revision: 1.12 $

Type: remote

Family: Misc.

Published: 2008/12/01

Modified: 2016/05/13

Dependencies: 10785

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/samba, SMB/NativeLanManager, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2008-4314

BID: 32494

OSVDB: 50230

Secunia: 32813

CWE: 200