Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

JBoss EAP < 4.2.0.CP04 / 4.3.0.CP02 Status Servlet Information Disclosure

Medium

Synopsis

The remote host is vulnerable to a flaw that allows attackers to retrieve sensitive files or data.

Description

The version of JBoss Enterprise Application Platform (EAP) running on the remote host allows attackers to download '.class' files. These files can be easily decompiled using a tool such as 'jad'. The attacker would then have access to the source code which could lead to more sophisticated attacks.

Solution

Upgrade to version 4.2.0.CP04, 4.3.0.CP02 or higher.