CVE-2008-3519

MEDIUM

Description

The default configuration of the JBossAs component in Red Hat JBoss Enterprise Application Platform (aka JBossEAP or EAP), possibly 4.2 before CP04 and 4.3 before CP02, when a production environment is enabled, sets the DownloadServerClasses property to true, which allows remote attackers to obtain sensitive information (non-EJB classes) via a download request, a different vulnerability than CVE-2008-3273.

References

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=458823

http://www.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/4.2.0.cp04/html-single/readme/index.html

http://www.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/4.3.0.cp02/html-single/readme/index.html

http://www.redhat.com/support/errata/RHSA-2008-0831.html

http://www.redhat.com/support/errata/RHSA-2008-0832.html

http://www.redhat.com/support/errata/RHSA-2008-0833.html

http://www.redhat.com/support/errata/RHSA-2008-0834.html

http://www.securityfocus.com/bid/31300

http://www.securitytracker.com/id?1020905

https://exchange.xforce.ibmcloud.com/vulnerabilities/45305

Details

Source: MITRE

Published: 2008-09-23

Updated: 2017-08-08

Type: CWE-16

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM