Apache 2.4.x < 2.4.43 Multiple Vulnerabilities

medium Web Application Scanning Plugin ID 98998
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Apache 2.4.x < 2.4.43 Multiple Vulnerabilities

Description

According to its banner, the version of Apache running on the remote host is 2.4.x prior to 2.4.43. It is, therefore, affected by multiple vulnerabilities:

- An uninitialized value vulnerability exists in mod_proxy_ftp. (CVE-2020-1934)

- An open redirect vulnerability exists in mod_rewrite. (CVE-2020-1927)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache version 2.4.43 or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.43

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.42

Plugin Details

Severity: Medium

ID: 98998

Type: remote

Published: 4/10/2020

Updated: 9/7/2021

Scan Template: api, scan, pci

Risk Information

CVSS Score Source: CVE-2020-1927

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:N

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 4/1/2020

Vulnerability Publication Date: 4/1/2020

Reference Information

CVE: CVE-2020-1934, CVE-2020-1927