nginx < 1.12.1 Integer Overflow

medium Web Application Scanning Plugin ID 98967

Synopsis

nginx < 1.12.1 Integer Overflow

Description

According to the self-reported version in its response header, the version of nginx hosted on the remote web server is < 1.13.3. It is, therefore, affected by an integer overflow vulnerability

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to nginx version 1.12.1 or later.

See Also

http://mailman.nginx.org/pipermail/nginx-announce/2017/000200.html

http://nginx.org/en/security_advisories.html

Plugin Details

Severity: Medium

ID: 98967

Type: remote

Published: 11/5/2018

Updated: 2/18/2020

Scan Template: api, scan, pci

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:2.3:a:nginx:nginx:*:*:*:*:*:*:*:*

Patch Publication Date: 7/11/2017

Vulnerability Publication Date: 7/11/2017

Reference Information

CVE: CVE-2017-7529