nginx < 1.13.3 Integer Overflow

Medium Web Application Scanning Plugin ID 98966

Synopsis

nginx < 1.13.3 Integer Overflow

Description

According to the self-reported version in its response header, the version of nginx hosted on the remote web server is < 1.13.3. It is, therefore, affected by an integer overflow vulnerability

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to nginx version 1.13.3 or later.

See Also

http://mailman.nginx.org/pipermail/nginx-announce/2017/000200.html

http://nginx.org/en/security_advisories.html

Plugin Details

Severity: Medium

ID: 98966

Type: remote

Published: 2018/11/05

Updated: 2020/02/18

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:2.3:a:nginx:nginx:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2017/07/11

Vulnerability Publication Date: 2017/07/11

Reference Information

CVE: CVE-2017-7529

BID: 99534

CWE: 190

WASC: Integer Overflows

OWASP: 2013-A9, 2017-A9