Apache Tomcat 9.0.0.M1 < 9.0.31 Multiple Vulnerabilities

High Web Application Scanning Plugin ID 98946

Synopsis

Apache Tomcat 9.0.0.M1 < 9.0.31 Multiple Vulnerabilities

Description

The version of Apache Tomcat installed on the remote host is 9.0.0.M1 to 9.0.30, 8.5.0 to 8.5.50 or 7.0.0 to 7.0.99. It is, therefore, affected by multiple vulnerabilities :

- An arbitrary file read vulnerability in AJP protocol due to an implementation defect which could also be leveraged to achieve remote code execution.

- A HTTP request smuggling vulnerability due to some invalid HTTP headers parsed as valid.

- A HTTP request smuggling vulnerability due to invalid Transfer-Encoding headers incorrectly processed.

Note that the scanner has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 9.0.31 or later.

See Also

http://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.31

Plugin Details

Severity: High

ID: 98946

Type: remote

Published: 2020/02/28

Updated: 2020/03/05

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apache:tomcat:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 2020/02/11

Vulnerability Publication Date: 2020/02/24

Reference Information

CVE: CVE-2020-1938, CVE-2020-1935, CVE-2019-17569