PHP 7.4.x < 7.4.2 Multiple Vulnerabilities

critical Web Application Scanning Plugin ID 98932
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

PHP 7.4.x < 7.4.2 Multiple Vulnerabilities

Description

According to its banner, the version of PHP running on the remote web server is prior to 7.2.27, 7.3.x prior to 7.3.14, or 7.4.x prior to 7.4.2. It is, therefore, affected by multiple vulnerabilities:

- A buffer overflow exists in mbfl_filt_conv_big5_wchar due to an input validation error. (CVE-2020-7060)

- An out-of-bounds READ error exists in php_strip_tags_ex due to an input validation error. (CVE-2020-7059)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.4.2 or later.

See Also

https://www.php.net/ChangeLog-7.php#7.4.2

https://www.php.net/index.php#2020-01-23-1

Plugin Details

Severity: Critical

ID: 98932

Type: remote

Published: 1/27/2020

Updated: 9/7/2021

Scan Template: api, scan, pci

Risk Information

CVSS Score Source: CVE-2020-7060

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 2/10/2020

Vulnerability Publication Date: 2/10/2020

Reference Information

CVE: CVE-2020-7060, CVE-2020-7059